Configuring Home Computers (Students) | Links for Success

Teresa -

Welcome to your Proximity Learning course

Before beginning your Proximity Learning course, you'll need to set up your computer and watch the orientation videos located with the Modules.

The instructions and links for success are below

After you have setup your computer and watched the orientation videos, you can access your coursework by clicking Login link in the upper right corner of http://proxlearn.com/

Obtain your Canvas credentials for the course from Myken Caviness(mcaviness@proxlearn.com) if you have not already.

If you have any trouble getting your computer setup, need general technical support, or just have questions about the course, please submit a ticket via the following link:

Submit a support ticket or send an email to support@proximity.zendesk.com.

System Requirements

  • Broadband connection (15mb/s download and 5mb/s upload speeds or higher recommended)  Test your Internet connection speed:  Speed Test
  • Computer with Windows or OSX operating system and at least 5GB of RAM (dual-core processor or better and 5GB of RAM or more strongly recommended).
  • Operating System: Windows 7 or newer,  Mac OSX 10.7.4 or newer.
  • Chromebooks are currently supported but must be updated to the latest version of Chrome OS.
  • Webcam
  • Headphones or earbuds and a microphone (most webcams have built in mics).  A headset with built-in mic is strongly recommended for an optimum live class experience. (Headsets are typically not required for Sign Language courses)

Examples of inexpensive headsets

Examples of inexpensive recommended webcams: 

Note:  Logitech webcams and headsets are recommended to ensure comparability and quality.  Microsoft brand headsets and webcams may work, but are not supported due to compatibility issues.

Browser

Please, install and use the latest version of Firefox. This is the most reliable browser for your Proximity Learning courses. With Microsoft Edge, Google Chrome and Safari as decent alternatives. IE10 and IE11 are supported, but may not work as well as other browsers. Older versions of Internet Explorer including IE7, IE8, and IE9 are not supported and important course features may not work with these older browsers. 

Click here to download Firefox

Note: The Chrome browser is supported but we must accomodate Flash!

Browser Plug-ins

Please install the most recent version all of the flowing required browser plug-ins:

Chinese or Japanese Input Method:

These steps are only necessary for students enrolled in Chinese or Japanese language courses

Instructions for enabling Japanese input on a standard US keyboard:

You must install the following Chinese input methods in order to type in Chinese characters and PinYin using a standard American keyboard.

Optional

 Extract and install the PinYin Editor (allows typing Pinyin with tone markers): 
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk